Clique abaixo para nos ajudar
Conectar-se

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
18 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 18 Visitantes :: 1 Motor de busca

Nenhum

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
TRY BEGIN E FLOCK()

17/4/2017, 10:32 por AJC

Pessoal estou tendo alguns problemas de gravação em rede, estou usando
try begin, mas vi algo na …

Comentários: 0

Exportar Dados Campo Memo Tabela DBF

10/4/2017, 10:28 por fcampos

Olá bom dia.

Estou tentando exportar os dados de algumas tabelas em formato dbf pelo foxpro.
O …

Comentários: 2

Função EVL()

8/4/2017, 12:18 por Clebervfp

Bom dia a todos.
Vim compartilhar de uma Função do próprio VFP que me benefício muito.
Função …

Comentários: 0

COMO BLOQUEAR REGISTRO OU TABELA NO VISUAL FOXPRO PARA GRAVAÇÃO EM REDE

3/4/2017, 10:29 por AJC

Pessoal estou tendo um problema que acontece sempre busco na minha tabela de clientes o ultimo …

Comentários: 2

Controlar Scanner Twain

31/3/2017, 17:31 por Kleber R Bento

Estou usando o EZTW32.DLL para criar uma ferramenta que escaneia e gera PDF. Porém com esses …

Comentários: 0

Estatísticas
Temos 7069 usuários registrados
O último usuário registrado atende pelo nome de drudru

Os nossos membros postaram um total de 48 mensagens em 25 assuntos

Imagem em Grid

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Imagem em Grid

Mensagem por jrinformatica em 4/1/2010, 20:32

galera seguinte. eu coloquei foto no meu form.. usei o exemplo do marcos.. eu baixei e ajustei ele no meu form ate ia blz... eu consigo coloca as fotos no form blz e qdo salvo o resgitro com a foto o sistema tb ta salvando blz. ai qdo eu vo no no meu item busca pra ver se os dados estao salvos corretamente eles estao todos la mas no campo da foto nao aparece a foto aparece o caminho da foto ex: c:\dados\fotos... entao eu keria saber como eu faço aparece a foto no grid de busca e aparecer tb dentro do form qdo eu uso os botoes proximo, anterios etc... nesse caso os registros aparecem perfeitamente so a foto q nao aparece.. onde sera q to errando??? valeu

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por Marcos Guedes em 4/1/2010, 21:37

Dê uma olhada neste tópico:
- [Você precisa estar registrado e conectado para ver este link.]

Resolve o problema?

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por jrinformatica em 5/1/2010, 08:14

blz marcos ele resolveu sim o do grid mas agora falta o do form q qdo eu clico nos botoes proximo, anterior pra ver os registros o sistema so me mostra os registros e a imagem q add nao aparece.. fala esse detalhe pra eu resolver mas nao to conseguindo...

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por Marcos Guedes em 5/1/2010, 08:36

tens como postar o teu form, ou projeto?

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por jrinformatica em 5/1/2010, 12:13

opa ta ai o link marcos

[Você precisa estar registrado e conectado para ver este link.]

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por Marcos Guedes em 6/1/2010, 13:28

jrinformatica, eu não sei ao certo como você está guardando o caminho de sua foto no banco. Mas uma alternativa de corrigir o problema é a seguinte:

- No método "INIT" de seu formulário, coloque o seguinte código:
Código:
*!* Define a configurações inicial
*!* para todos os controles

THISFORM.coordenacontroles ("D")

*!* Define a configuração inicial
*!* para os botões

THISFORM.coordernabotoes ("Padrão")

Atualiza a foto
SELECT tabela
GO TOP && Vai para o primeiro registro
THISFORM.image1.PICTURE=tabela.foto

- No método "Click" do botão "Próximo" adicione o seguinte código:
Código:
THISFORM.coordenanavegacao("Primeiro")
IF NOT EOF()
   SKIP
ENDIF
thisform.image1.Picture=tabela.foto && Atualiza a foto
THISFORM.REFRESH

- No método "Click" do botão "Anterior" adicione o seguinte código:
Código:
THISFORM.coordenanavegacao ("Anterior")
IF NOT BOF()
   SKIP -1
ENDIF
THISFORM.image1.PICTURE=tabela.foto && Atualiza a foto
THISFORM.REFRESH

Obs.: Estas modificações são com base no que você já fez, pois eu não tive tempo de analisar o seu código.

Para lhe auxiliar, estou mandando a atualização que fiz em seu projeto para que ele funcione corretamente (Observe na tabela o caminho do arquivo!).

Clique aqui para baixar o arquivo!

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por hugo em 6/1/2010, 14:59

parabens pelo empenho marcos

valeu cara, assim o forum vai bombar dada vez mais!

_________________
"A tristeza é a falta de alegria, mais sem ela eu não poderia entender a alegria do fato de que a felicidade existe!"
Helio Leites - [Você precisa estar registrado e conectado para ver este link.]
avatar
hugo
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por jrinformatica em 6/1/2010, 15:38

ai marcos blz...entao fera eu vi as alterações q vc vez... fico legal o q eu to querendo mesmo é q aparece a foto dentro do from.. assim qdo eu for ver os registro atraves dos botoes proximo, anterios etc vai aparecer na tela alem dos registro a foto do cliente tb. nesse meu caso agora alem dos registros esta aparecendo o caminho da foto e nao a foto como deveria ser.... ja fiz aquela alteraçao q vc me pediu sobre a tabela.foto e tabela.txtfoto... sempre da o erro de foto ou txfoto nao encontrado sendo q tem esse campo dentor da tabela.... Eu tava pensando aki dentro do meu dbf o campo foto ta como caracter sera q nao tenho q alterar nada la dentro pra resolver isso???? valeu

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por Marcos Guedes em 6/1/2010, 15:53

Se você estiver se referindo ao erro do botão "Add", substitua o código do método "Click", do botão, por este:
Código:
*!* replace "c:\eurocar\foto" WITH "c:\eurocar\foto\001.jpg"

x=GETPICT('jpg;bmp;pcx;gif','Selecionar a Foto','Selecionar')
IF ! EMPTY(x)
   x=[']+x+[']
   SELECT tabela
   THISFORM.image1.PICTURE=SPACE(200)
   WITH THISFORM
      .txtfoto.VALUE=1
      .image1.PICTURE = &x &&caminho
      .txtfoto.VALUE= &x
   ENDWITH
ENDIF

O erro ocorria por que você escreveu .txtfoto=1 ao invés de .txtfoto.VALUE=1

Resolve o problema?


Última edição por Marcos Guedes em 7/1/2010, 11:18, editado 1 vez(es)

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por jrinformatica em 6/1/2010, 16:15

marcos acabei de fazer a alteração aki mas nao funcionou nao... o problema ta so na foto pq o resto ta de boa... vou explicar... eu clico em novo pra cadastrar ai blz. depois vo no add pra colocar a foto ate ai blz.. a janela abre e funciona perfeitamente mas qdo eu seleciono a foto e clico em ok pra add ela no form ai da o erro.. ai se eu manda igonrar o sistema add a foto e quando clico em grava ele grava todo os campo do registro so a foto q nao????

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por Marcos Guedes em 6/1/2010, 16:24

Pelo que descrevesse, você não fez a alteração que eu sugeri.
Estou enviando os arquivos atualizados.

- Clique aqui para baixar o arquivo!

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por jrinformatica em 6/1/2010, 16:49

eu fiz todas as alterações sim marcos mas esta do mesmo jeito.... agora eu troquei o codigo to usando um q vc postou ai sobre form com fotos mas nele vc fez com grid. eu ja adequei ele ao meu form mas nao funcionou ainda... agora vo voltar ao codigo antigo pra testar com o exe q vc postou ai... ja ja eu respondose funciono u ou nao...

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por jrinformatica em 6/1/2010, 17:02

entao marcos fiz o teste mas continua do mesmo jeito. vo coocar o erro abaixo aki pra vc ver:
Ha ocurrido un error:
Numero de error:1925
Mensaje de error: Unknown member FOTO
Linha de codigo con error:
Numero da inha do error:37
Programa con error: form1.command2.click

se eu clicar em ignorar ai apaaparece esses erros tudo so mundando a linha para linha 39...
marcos agora estou indo embora do meu serviço. vou tentar arruma isso la em casa a noite ok... mas vo seguir tentando aki... valeu

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por Marcos Guedes em 6/1/2010, 17:07

jrinformatica, enviei o arquivo errado! Embarassed

- Clique aqui para baixar o arquivo atualizado!

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por jrinformatica em 7/1/2010, 11:08

ai marcos agora ta blz.. ta funcionando certinho... so tenho uma pergunta pra vc.. o q vc fez nele pq eu nao to conseguindo axar a alteração..rsrss ta iguazinho ao projeto anterior q eu tenho aqui..rsrss queria sabe onde vc alterou o codigo pra q eu possa ver e aprender...srsrssss
mas de qualquer forma obrigado pela ajuda.. ja to conseguindo resolver outros problemas aqui é q a gente vai se familiarizando com a liguagem ne..rsrs mas valeu mesmo...rsrs
obrigado

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por Marcos Guedes em 7/1/2010, 11:16

Eu fiz exatamente o que havia citado:
[Você precisa estar registrado e conectado para ver este link.] escreveu:Se você estiver se referindo ao erro do botão "Add", substitua o código do método "Click", do botão, por este:
Código:
*!* replace "c:\eurocar\foto" WITH "c:\eurocar\foto\001.jpg"

x=GETPICT('jpg;bmp;pcx;gif','Selecionar a Foto','Selecionar')
IF ! EMPTY(x)
   x=[']+x+[']
   SELECT tabela
   THISFORM.image1.PICTURE=SPACE(200)
   WITH THISFORM
      .txtfoto.VALUE=1
      .image1.PICTURE = &x &&caminho
      .txtfoto.VALUE= &x
   ENDWITH
ENDIF

O erro ocorria por que você escreveu .txtfoto=1 ao invés de .txtfoto.VALUE=1

Resolve o problema?
Very Happy

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Imagem em Grid

Mensagem por jrinformatica em 7/1/2010, 14:49

mas eu fiz isso sim... mas nao funcionou... axo q tava dando erro pq aem de alterar isso q vc faou eu tinha colocado mais coisas dentor do botao gravar e agora nao tem mais nada la dentro dele... mas agora ta blz marcos valeu... a tudo funcionando... valeu mesmo.. obrigado....rsrsss

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum