Clique abaixo para nos ajudar
Login

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
19 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 19 Visitantes :: 2 Motores de busca

Nenhum

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
Últimos assuntos
» Buscar endereço por CEP
3/12/2016, 19:59 por pedrossian

» USAR WEBSERVICE NO VFP9
2/12/2016, 09:50 por AJC

» BANIMENTO DE USUARIO
17/11/2016, 08:31 por FAF

» Impressora Ticket
15/11/2016, 09:20 por clima238

» Gráfico
9/11/2016, 10:43 por hidroluz

» TRANSPOR TABELA
9/11/2016, 10:34 por hidroluz

» MUDANÇA DO .DBF PARA POTSGREE
9/11/2016, 09:12 por AJC

» Website com videoaulas sobre linguagens de programação
8/11/2016, 09:56 por JLDR

» Parceria para desenvolvimento de template em Wordpress
7/11/2016, 19:15 por mindix

» Data fica invertida na planilha que é gerada via programa.
27/10/2016, 11:00 por Linghston

» Maximizar report direto do menu
21/10/2016, 20:48 por Rosangela Pires

» Fechar form com tempo
21/10/2016, 10:15 por Rosangela Pires

» URGENTE: Ajuda com impressora ELGIN-L42
14/10/2016, 09:53 por megasoft

» Opções para gerar NF-e
10/10/2016, 09:07 por mavsinfo

» Google Maps
8/10/2016, 15:08 por Rosangela Pires

» Mysql
5/10/2016, 11:22 por Marcos Guedes

» Acessando Banco em MYSQL de um projeto WORDPRESS
3/10/2016, 10:58 por Marcos Guedes

» OPTION SELECT MOSTRAR CAMPOS QUASE PRONTO
26/9/2016, 21:09 por BobKuspe

» Pesquisa em grid
14/9/2016, 09:24 por AJC

» Total Code Generator
9/9/2016, 17:43 por robsonpassos

Buscar endereço por CEP

3/12/2016, 19:59 por pedrossian

Caros amigos, meu código para buscar endereço pelo CEP não funciona mais.
Alguém pode me …

Comentários: 0

USAR WEBSERVICE NO VFP9

2/12/2016, 09:50 por AJC

Pessoal, preciso de um material ou livro que me traga instruções como
usar a consumação de …

Comentários: 0

BANIMENTO DE USUARIO

13/11/2016, 16:21 por FAF

A usuária ROSANGELA PIRES ao tentar acessar o Forum obtem sempre a mensagem de BANIMENTO.
A mesma …

Comentários: 3

Impressora Ticket

15/11/2016, 09:20 por clima238

Bom dia,
Por favor alguém me explique porque o código abaixo imprime no ecrã em vez do printer: …

Comentários: 0

TRANSPOR TABELA

9/11/2016, 10:34 por hidroluz

Bom dia a todos, gostaria de saber como consigo fazer a transposição de uma tabela no VFP.



Comentários: 0

Estatísticas
Temos 6959 usuários registrados
O último usuário registrado atende pelo nome de EDBERTO

Os nossos membros postaram um total de 17117 mensagens em 2575 assuntos

Problemas com projeto em rede

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Problemas com projeto em rede

Mensagem por jrinformatica em 4/1/2010, 11:57

galera to com um probleminha aki. meu projeta a funcionando legalzinho. agora fui colocar ele na rede mas ele noa funciona.. o programa ate abre mas nao grava os registros... ai procurei um solução aki e achei um dica pra colocar o comando set exclusive off no prg principal... ja fiz
achei tb use tabela shared ... ja fiz
depois achei USE tabela IN SELECT("tabela")SHARED tb ja fiz e nao ta funciando... em relação ao use tabela eu nao sei onde coloco dai eu coloquei dentro do prg principal, dentro do form no init mesmo asim nao ta funcionando... onde sera q estou errando.. a minha rede ta blz... ta tudo compartilhado a pasta os atalhos tud certo. sera q pode ser tb o meu servidor??? o meu servidor é o win 7 e o resto é xp sp3. se alguem tive uma luz ai.. valeu
esqueci ta copiei todas as dlls pras estações tb... valeu


Última edição por jrinformatica em 4/1/2010, 12:08, editado 1 vez(es)

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por Marcos Guedes em 4/1/2010, 12:03

Alguma mensagem de erro?

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por jrinformatica em 4/1/2010, 12:12

sim...
uniqueness of index CODIGO is violated

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por Marcos Guedes em 4/1/2010, 12:19

Você deve ter definido o indice CODIGO como sendo do tipo "Primary" ou "Candidate"!
O erro não está ocorrendo por que sua aplicação foi colocada em rede, mas sim pelo fato de você estar tentando incluir valores iguais para o campo CODIGO.

Se sua aplicação permitir o mesmo código para a tabela em questão, então deixe o indice "CODIGO" com tipo "Regular".

Resolve o problema?

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por jrinformatica em 4/1/2010, 12:24

sim isso mesmo marcos eu deixei como primary.. entao tem q deixa como regular... vo testa aki e ja coloca a resposta....

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por jrinformatica em 4/1/2010, 12:31

entao marcos deu certinho... era isso mesmo a chave primaria...rsrs agora ta gravando sim.... so q tem um outro probleminha aki... qdo eu peço um registro novo ele vai normal mas o codigo nao muda.. se eu ja cadastrei o 0001 ele teria q ir pro 0002... antes de eu colocar na rede tava blz.. agora se eu pedi regisTRO novo ele sempre da 0001 e o engraçado é q isso é so no servidor... nas estações ta perfeito..??? o q sera??? crtz é alguma coisa q eu fiz

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por Marcos Guedes em 4/1/2010, 12:35

Talvez a melhor solução não seria você mudar o tipo do indice, mas sim corrigir o modo como o código é gerado.

como você está gerando este código?

Vai uma sugestão. Talvez você ache interessante utilizá-la:
Dependendo da forma como você está fazendo o seu projeto, você poderia deixar o campo CODIGO do tipo CARACTER(10).
Sempre que for adicionar um registro que necessite de um novo código, você utiliza o retorno da função SYS(2015). Esta função gera uma sequência de 10 caracteres que nunca se repete.

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por jrinformatica em 4/1/2010, 12:36

descobri outra coisa isso ta ocorrendo em todos os pcs... parece q ele começo a grava os registor do zero tendeu... tipo antigamente sem a rede ele gravado certo.. agora ele continua gravando certo ainda mas ele ta gravando tudo com o mesmo codigo denovo.. entao aki tem 2 registros 0001 2 registro 0002 e por ai vai. acho q o sistema ta fazendo isso pq mudo a chave pra regular... se eu apagar todos os registro e cmeça do zero acho q ele grava tudo certo??? sera????

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por jrinformatica em 4/1/2010, 12:44

ai marcos acho q era aquilo mesmo q te falei da gravação qdo era primary ele gravava de boa qdo mudei pra regular parece q ele entendeu q era pra começar do zero tendeu ai ele começo a grava tudo denovo. ai fui la e apaguei tudo.. agora ele ta gravando blz.. eu so apaguei pq podia ne.. pq é tudo teste aki..rsrs mas agora ele ta blz denovo valeu mesmo pelo hep ai..rsrs
agora quero aber com eu uso esse SYS(2015). eu coloco esse comando no prg principal e so isso ou precisa de outra coisa. to perguntando pq sou novo em vfp...rsrsrss
valeu mesmo

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por Marcos Guedes em 4/1/2010, 12:50

Acredito que este exemplo lhe ajudará a compreender o uso da função SYS(2015):
Código:
CREATE CURSOR teste (codigo c(10)) && Cria um cursor teste
SELECT teste && Seleciona o cursor criado
*!* Define um indice primário para o campo "codigo"
*!* Se houver tentativas de inclusão de registro com o mesmo valor,
*!* haverá um erro de violação do campo
INDEX ON codigo TAG codigo ASCENDING CANDIDATE

LOCAL contador AS INTEGER && Define uma variável do tipo inteiro
FOR m.contador=1 TO 10000
   *!* Insere 10.000 (Dez mil) registros na tabela teste (Sem repetição)
   INSERT INTO teste (codigo) VALUES (SYS(2015))
ENDFOR

SELECT teste && Seleciona o cursor teste, novamente
BROWSE && Exibe o cursor

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por jrinformatica em 4/1/2010, 12:53

ok marcos vou testa-o mais tarde e depois te falo se deu certo ok... mas valeu pela ajuda...

t+
Valeuuuuu..rsrs

jrinformatica
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por hugo em 4/1/2010, 13:08

este eh o marcao!@ heheh

_________________
"A tristeza é a falta de alegria, mais sem ela eu não poderia entender a alegria do fato de que a felicidade existe!"
Helio Leites - [Você precisa estar registrado e conectado para ver este link.]

hugo
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Problemas com projeto em rede

Mensagem por Conteúdo patrocinado Hoje à(s) 09:28


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum