Clique abaixo para nos ajudar
Conectar-se

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
25 usuários online :: 1 usuário cadastrado, Nenhum Invisível e 24 Visitantes :: 2 Motores de busca

newtonrio

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
Erro de compatibilidade de cores

28/3/2017, 10:59 por Clebervfp

Boa dia, estou com um problema com vfp9, se alguém poder me ajudar fico agradecido!

Tenho um …

Comentários: 0

Espessura do cursor intermitente

7/3/2017, 09:08 por Jefferson Matakas

Bom dia a todos !!

Existe uma opcao no windows que pode ser acessada atraves da 'central da …

Comentários: 0

DESENVOLVIMENTO EM REDES

4/3/2017, 18:45 por AJC

Pessoal tem ou conhece livros ou material para programação em
redes usando banco de dados nativo …

Comentários: 0

USAR REPORT FORM

30/12/2016, 09:06 por AJC

Pessoal bom dia,
Estou com um grande problema, já pesquisei muita coisa sobre report form, mas o …

Comentários: 4

Como preencher campos vazios

9/2/2017, 11:55 por Linghston

Pessoal boa tarde,

É o seguinte, eu preciso preencher os campos de uma coluna da tabela DBF que …

Comentários: 2

Estatísticas
Temos 7042 usuários registrados
O último usuário registrado atende pelo nome de brunobpc77

Os nossos membros postaram um total de 32 mensagens em 18 assuntos

EXIBIR CÓDIGO INEXISTENTE

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

EXIBIR CÓDIGO INEXISTENTE

Mensagem por marcos2016 em 7/4/2016, 18:23

TENHO O SEGUINTE CÓDIGO:

algoritmo "AUMENTO DE SALÁRIO DE ACORDO COM O CARGO"
var
salat, nsal, aumento: real
perc, codcarg: inteiro
inicio
escreva("CODIGO DO CARGO DO FUNCIONÁRIO: ")
leia(codcarg)
escreva("ATUAL SALÁRIO DO FUNCIONÁRIO EM R$: ")
leia(salat)
se (codcarg = 1) entao
escreval("CARGO: FAXINEIRO")
aumento <- salat * 50 / 100
escreval("O AUMENTO É DE: ",aumento)
nsal <- aumento + salat
escreva("O NOVO SALÁRIO DESTE CARGO É DE: ",nsal)
senao
se (codcarg = 2) entao
escreval("CARGO: RECEPCIONISTA")
aumento <- salat * 35 / 100
escreval("O AUMENTO É DE: ", aumento)
nsal <- salat + aumento
escreva("O NOVO SALÁRIO DESTE CARGO É DE: ", nsal)
senao
escreva("CODIGO INEXISTENTE!!!!")
fimse
fimse
fimalgoritmo

OBS: QUANDO EU EXECUTO O PROGRAMA E DIGITO O CÓDIGO 3 POR EXEMPLO, O PROGRAMA AINDA PEDE PARA DIGITAR O SALÁRIO DO CARGO, MAS QUERO UMA MANEIRA DE QUANDO EU DIGITAR DO CÓDIGO 3 EM DIANTE O PROGRAMA JÁ MOSTRE A SEGUINTE MENSAGEM: CÓDIGO INEXISTENTE!!!

OBRIGADO.

marcos2016
Participa Pouco
Participa Pouco


Voltar ao Topo Ir em baixo

USO DOCASE

Mensagem por MARCOS em 19/5/2016, 10:02

PRIMEIRO ESPERO QUE TENHA UM FORMULARIO , UMA TABELA COM OS CAMPOS
CODCARGO, ETC...
DO CASE
CASE CODCARGO=1
... CALCULA AQUI
CASE CODCARGO=2
... CALCULAR AQUI
OTHER
MESSAGEBOX("CODIGO INEXISTENTE!!")
ENDCASE

MARCOS
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum