Clique abaixo para nos ajudar
Conectar-se

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
20 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 20 Visitantes :: 1 Motor de busca

Nenhum

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
TRY BEGIN E FLOCK()

17/4/2017, 10:32 por AJC

Pessoal estou tendo alguns problemas de gravação em rede, estou usando
try begin, mas vi algo na …

Comentários: 0

Exportar Dados Campo Memo Tabela DBF

10/4/2017, 10:28 por fcampos

Olá bom dia.

Estou tentando exportar os dados de algumas tabelas em formato dbf pelo foxpro.
O …

Comentários: 2

Função EVL()

8/4/2017, 12:18 por Clebervfp

Bom dia a todos.
Vim compartilhar de uma Função do próprio VFP que me benefício muito.
Função …

Comentários: 0

COMO BLOQUEAR REGISTRO OU TABELA NO VISUAL FOXPRO PARA GRAVAÇÃO EM REDE

3/4/2017, 10:29 por AJC

Pessoal estou tendo um problema que acontece sempre busco na minha tabela de clientes o ultimo …

Comentários: 2

Controlar Scanner Twain

31/3/2017, 17:31 por Kleber R Bento

Estou usando o EZTW32.DLL para criar uma ferramenta que escaneia e gera PDF. Porém com esses …

Comentários: 0

Estatísticas
Temos 7069 usuários registrados
O último usuário registrado atende pelo nome de drudru

Os nossos membros postaram um total de 48 mensagens em 25 assuntos

Enviando Emails!

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Anexo Enviando Emails!

Mensagem por Marcos Guedes em 5/8/2009, 20:43

Encontrei estas soluções achei por bem divulgar aos colegas:

Para envio de emais, em geral, baixem o arquivo "VFPwinsock.zip" contido neste link:
[Você precisa estar registrado e conectado para ver este link.]

No link abaixo serão encontradas várias formas de utilização da rotina:
[Você precisa estar registrado e conectado para ver este link.]

Achei por bem destacar um exemplo utilizando uma conta do yahoo:
Código:
SET PROCEDURE TO VFPwinsock
o=CREATEOBJECT("VFP_Winsock_Send_Mail")
o.SMTP_HOST = "smtp.mail.yahoo.com.br"
o.FROM = "seuEmail@yahoo.com.br"
o.TO = "emailDestino@dominio.com"
o.Subject = "Encontrei no Programação Brasil"
o.Message = "Mensagem do email"
o.Auth_Login = "seuEmail@yahoo.com.br"
o.Auth_password = "suaSenha"
IF NOT o.send()
  ? "Error : " + o.Erreur
ENDIF
o=Null

Confira os outros exemplos no link que sugeri. Vale apena!
Very Happy


Última edição por Marcos Guedes em 25/1/2011, 15:20, editado 1 vez(es)

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por mfelis em 6/8/2009, 08:59

Muito util não conseguei configurar para enviar pelo servidor do gmail
avatar
mfelis
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por Marcos Guedes em 6/8/2009, 10:11

O Gmail, além de requerer autenticação, trabalha com a porta SMTP 465.
Dê uma olhada na rotina e veja se é possível se conectar a porta 465.
Tentei, mas não conseguir!

No caso do yahoo, a porta SMTP é padrão, 25.

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por Marcos Guedes em 10/8/2009, 17:43

Segue uma grande observação!

Para que esta rotina funcione perfeitamente em máquinas que não tenham o VFP instalado, é necessário habilitar uma lincença no registro do windows.

Para isto você poderá criar um arquivo chamado habilitar.reg, por exemplo, e colocar o seguinte conteúdo:
Código:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Licenses\2c49f800-c2dd-11cf-9ad6-0080c7e7b78d]
@="mlrljgrlhltlngjlthrligklpkrhllglqlrk"
Após criado o arquivo, execute-o e clique em sim/yes.

Outra alternativa é incluir estes valores manualmente no registro, ou criar uma função em fox para isto.

Se preferir, baixe o arquivo no link abaixo e dê um duplo clique, logo em seguida clique em sim/yes.
Clique aqui!

Fonte da dica:
[Você precisa estar registrado e conectado para ver este link.]

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por Marcos Guedes em 25/1/2011, 15:30

Link de exemplos similar (Os originais estão quebrados):
[Você precisa estar registrado e conectado para ver este link.]

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por Julio em 26/1/2011, 08:35

Boa Marcos

Vou dar uma olhada e realizar testes

Reputado!


Julio
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por memarques em 1/2/2011, 11:15

pessoal, na minha maquina o winsock numa maquina com XP, deu mensagem de erro. Rodei o habilitar.reg e funcionou na boa.

Fiz a mesma coisa com uma maquina com windows server 2003 e mesmo rodando o habilitar, o problema continua. Alguem sabe se existe alguma diferença que deve ser colocado no registro de um 2003 em relação a um XP?

Obrigado
Mauro

memarques
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por Marcos Guedes em 1/2/2011, 12:23

Se você executou no 2003 como administrador, e não resolveu, siga a orientação da quarta mensagem deste tópico:
[Você precisa estar registrado e conectado para ver este link.]

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por memarques em 1/2/2011, 12:45

Marcos

Obrigado. O que rolou foi q a OCX não tava registrada (além dos dados no registro). Agora funcionou ok. Coisa de ignorante como este que lhe escreve, sorry.

Abraço
Mauro

memarques
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por coconaithy em 8/7/2011, 19:51

testei a rotina e deu certo.
preciso saber para configuração exchange, alguém pode me ajudar.
tenho uma aplicação que fica rodando no serivodor validando registro. quando encontro um erro gravo numa tabela.
preciso incluir nesta rotina que assim que gravar o log nesta tabela é disparado um email informando o erro. so que a configuração do e-mail da empresa é via exchange.

coconaithy
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por coconaithy em 9/7/2011, 08:13

[Você precisa estar registrado e conectado para ver este link.] escreveu:testei a rotina e deu certo.
preciso saber para configuração exchange, alguém pode me ajudar.
tenho uma aplicação que fica rodando no serivodor validando registro. quando encontro um erro gravo numa tabela.
preciso incluir nesta rotina que assim que gravar o log nesta tabela é disparado um email informando o erro. so que a configuração do e-mail da empresa é via exchange.

Mais uma informação testei em casa deu certo, no meu serviço não, pode ser que firewall esteja bloqueando?

coconaithy
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por Marcos Guedes em 9/7/2011, 08:56

[Você precisa estar registrado e conectado para ver este link.] escreveu:testei a rotina e deu certo.
preciso saber para configuração exchange, alguém pode me ajudar.
tenho uma aplicação que fica rodando no serivodor validando registro. quando encontro um erro gravo numa tabela.
preciso incluir nesta rotina que assim que gravar o log nesta tabela é disparado um email informando o erro. so que a configuração do e-mail da empresa é via exchange.
Favor abrir outro tópico para não misturar os assuntos.


Obrigado!

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por Marcos Guedes em 9/7/2011, 08:57

[Você precisa estar registrado e conectado para ver este link.] escreveu:Mais uma informação testei em casa deu certo, no meu serviço não, pode ser que firewall esteja bloqueando?
Provavelmente, sim!

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por coconaithy em 9/7/2011, 11:27

Marcos, bom dia.
estive verificando, a politica da empresa que prestamos serviço bloquea as portas para SMPT e POP, somente é liberado a configuração exchange e https, você conhece outro modo?

coconaithy
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Anexo Re: Enviando Emails!

Mensagem por Marcos Guedes em 11/7/2011, 13:22

Vocês têm servidor web que rode PHP, ASP.NET, asp...?

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum