Clique abaixo para nos ajudar
Conectar-se

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
27 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 27 Visitantes :: 2 Motores de busca

Nenhum

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
TRY BEGIN E FLOCK()

17/4/2017, 10:32 por AJC

Pessoal estou tendo alguns problemas de gravação em rede, estou usando
try begin, mas vi algo na …

Comentários: 0

Exportar Dados Campo Memo Tabela DBF

10/4/2017, 10:28 por fcampos

Olá bom dia.

Estou tentando exportar os dados de algumas tabelas em formato dbf pelo foxpro.
O …

Comentários: 2

Função EVL()

8/4/2017, 12:18 por Clebervfp

Bom dia a todos.
Vim compartilhar de uma Função do próprio VFP que me benefício muito.
Função …

Comentários: 0

COMO BLOQUEAR REGISTRO OU TABELA NO VISUAL FOXPRO PARA GRAVAÇÃO EM REDE

3/4/2017, 10:29 por AJC

Pessoal estou tendo um problema que acontece sempre busco na minha tabela de clientes o ultimo …

Comentários: 2

Controlar Scanner Twain

31/3/2017, 17:31 por Kleber R Bento

Estou usando o EZTW32.DLL para criar uma ferramenta que escaneia e gera PDF. Porém com esses …

Comentários: 0

Estatísticas
Temos 7064 usuários registrados
O último usuário registrado atende pelo nome de Rpedrozo

Os nossos membros postaram um total de 48 mensagens em 25 assuntos

Executável rodando oculto

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Executável rodando oculto

Mensagem por halisson em 22/2/2013, 12:55

-
Olá senhores do Fox!

Marcos, Alceu e os demais, tudo certinho?

Faz um bom tempo que não entro no fórum, eu sei.
Estou dedicado aos freelas e a um projeto web opensource
chamado PHP-Fusion. [Você precisa estar registrado e conectado para ver este link.]

Bem, indo direto ao help, a situação é a seguinte:

Tenho um sistema VFP9 rodando em uma empresa a mais de um ano.
A dois dias atrás, por algum motivo que acredito ser no Windows,
(nesse caso a versão é o Windows 7 mas creio que aconteceria
em qualquer versão
), o executável é iniciado oculto, ou seja,
a interface não abre, nem minimizado na barra, simplesmente oculto.
No entanto, ele se encontra ativo e rodando no "Gerenciador de Tarefas".

Obs. Nos outros computadores da rede, também com windows,
o aplicativo está rodando normal sem problema nenhum.[/b]

Alguém já passou por problema semelhante?
Ou teria uma sugestão pra solucionar esse problema?

Tentativas:

- Restaurei o Windows para um ponto de restauração anterior ao do problema;
- Reinstalei Runtimes do VFP9;
- Copiei dlls e executáveis de outras máquinas para essa máquina problemática,
e não funcionou.

Aguardo algum comentário,

obrigado
-
avatar
halisson
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Executável rodando oculto

Mensagem por alceu11 em 22/2/2013, 14:29

Infelismente dei baixa no forum VFP no dia 18/2/12 nao Participo
mais, .....

Boa Sorte
avatar
alceu11
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Executável rodando oculto

Mensagem por Marcos Guedes em 22/2/2013, 14:45

Halisson, como é o ciclo de funcionamento de sua aplicação?
Não será que você trabalha com leitura de alguma informação antes da inicialização (seja num arquivo ou base de dados) e que está impedindo que sua aplicação seja exibida?



[Você precisa estar registrado e conectado para ver este link.] escreveu:Infelismente dei baixa no forum VFP no dia 18/2/12 nao Participo
mais, .....

Boa Sorte
Alceu, meu caro... sinto muito pelo VFP (também sofri para aceitar que um dia iria acabar). Mas a vida é assim... Em breve acredito que você estará conosco no .NET

Smile

Contudo, não desanime... O VFP ainda é utilizado.

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Executável rodando oculto

Mensagem por halisson em 22/2/2013, 15:35

-
[Você precisa estar registrado e conectado para ver este link.] escreveu:Infelismente dei baixa no forum VFP no dia 18/2/12 nao Participo
mais...

não deve ter sido uma decisão fácil. você foi um dos os pilares
que sustentavam e ainda sustentam esse fórum (lembre-se:
o seu legado permanece
). obrigado Alceu.

[Você precisa estar registrado e conectado para ver este link.] escreveu:Halisson, como é o ciclo de funcionamento de sua aplicação?
Não será que você trabalha com leitura de alguma informação antes da inicialização (seja num arquivo ou base de dados) e que está impedindo que sua aplicação seja exibida?

Marcos, é um executável que apenas faz consultas em DBF. Basicamente.
sempre funcionou durante muitos meses. e funciona em outras máquinas.

Contudo, esqueci de mencionar que eu consegui abrir uma outra aplicação
só que bem mais simples. Porém isso não isenta totalmente o Windows.

Tenho que encontrar um jeito de descobrir o que exatamente
está provocando essa reação inesperada do windows de ocultar
a minha aplicação principal.

Alguma ideia de onde posso começar com essa depuração?
Talvez o prg que inicializa o sistema? Acho mais óbvio, certo?

Abraço
-
avatar
halisson
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Resolvido Re: Executável rodando oculto

Mensagem por halisson em 1/3/2013, 10:28

-
arquivo DBF com algum tipo de corrupção.

o init do form de login faz uso de uma consulta.
porém após essa consulta, o sistema continuava a
execução de forma totalmente oculta no windows,
ficando visível apenas no gerenciador de tarefas.

verifiquei isso fazendo uma depuração minuciosa.
substitui a tabela em questão por outra "zerada"
e o sistema funcionou normalmente.

obrigado a todos.
-



avatar
halisson
Participante Regular
Participante Regular


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum