Clique abaixo para nos ajudar
Conectar-se

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
24 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 24 Visitantes :: 2 Motores de busca

Nenhum

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
Espessura do cursor intermitente

7/3/2017, 09:08 por Jefferson Matakas

Bom dia a todos !!

Existe uma opcao no windows que pode ser acessada atraves da 'central da …

Comentários: 0

DESENVOLVIMENTO EM REDES

4/3/2017, 18:45 por AJC

Pessoal tem ou conhece livros ou material para programação em
redes usando banco de dados nativo …

Comentários: 0

USAR REPORT FORM

30/12/2016, 09:06 por AJC

Pessoal bom dia,
Estou com um grande problema, já pesquisei muita coisa sobre report form, mas o …

Comentários: 4

Como preencher campos vazios

9/2/2017, 11:55 por Linghston

Pessoal boa tarde,

É o seguinte, eu preciso preencher os campos de uma coluna da tabela DBF que …

Comentários: 2

Enviar msg para WhatsAPP via VFP

7/2/2017, 10:31 por Eliana

Olá Pessoal!

Alguém sabe se é possível enviar mensagem para o WhatsAPP via VFP?


Grata


Comentários: 0

Estatísticas
Temos 7038 usuários registrados
O último usuário registrado atende pelo nome de CASTROCV

Os nossos membros postaram um total de 31 mensagens em 17 assuntos

Problema de Campo Bit no CursorAdapter

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Problema de Campo Bit no CursorAdapter

Mensagem por EdinaldoRocha em 7/2/2013, 08:25

Bom dia pessoal.
Tenho problema: Quando gero o CursorAdapter de uma tabela que contem alguns campos Bit(1) no squema carrega campo memo; Exe.: Na tabela clientes o campo cl_sit é bit(1) no squema do cursor vem cl_sit M.
Como solucionar ?


EdinaldoRocha
Participa Pouco
Participa Pouco


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por Marcos Guedes em 8/2/2013, 08:35

Você está gerando o CursorAdapter em que linguagem, Edinaldo?
E qual a razão de usares o campo Bit?

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
http://portal.programacaobrasil.com

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por EdinaldoRocha em 11/2/2013, 16:04

Boa tarde Marcos

Estou gerando o CA no VFOX90 sp2.

Estou convertendo minha aplicação de VFOX50 para VFOX90 e os meus campos bits foram convertidos corretamente, porem quando gero o cursoradapter estes campos no squema chegam como Memo e não Logical como deveria ser.

Agradeço qualquer dica para solucionar este problema.

EdinaldoRocha
Participa Pouco
Participa Pouco


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por Nelson Arcas em 12/2/2013, 17:44

Edinaldo,

Você está utilizando o cursoradapter para fazer a leitura de algum banco de dados específico como (SQL, POSTGRE, FIREBIRD) ou de tabelas dbf?

Tive um problema assim com o postgre mas era uma problema da forma que estava capturando os dados de uma stored procedure.

Abs
avatar
Nelson Arcas
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por EdinaldoRocha em 13/2/2013, 10:55

Bom dia Nelson.
Tenho o Database já convertido, quando gero o CA da tabela, os campos definidos como BIT(1) vem como M e não como L.

Gostaria de sugestão para resolver esta problema.

Obrigado.

EdinaldoRocha
Participa Pouco
Participa Pouco


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por Nelson Arcas em 13/2/2013, 12:00

Olá Edinaldo, preciso saber em qual banco você converteu e qual a versão do drive que está usando.

Abs,

avatar
Nelson Arcas
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por EdinaldoRocha em 13/2/2013, 17:18

Olá Nelson, boa tarde.

Eu trabalho com DBA Postgresql.

Driver ODBC 6.1.7600

Grato pela atenção.

EdinaldoRocha
Participa Pouco
Participa Pouco


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por Marcos Guedes em 14/2/2013, 08:45

Edinaldo, por que utilizar um campo Bit ao invés de um CHAR(1) ?

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
http://portal.programacaobrasil.com

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por EdinaldoRocha em 14/2/2013, 13:05

Boa tarde Marcos.

Eu tive que mudar o campo para Char(3) "SIM" OU "NÃO"

Aí o problema foi solucionado.

Obrigado pelas resposta.

EdinaldoRocha
Participa Pouco
Participa Pouco


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por Marcos Guedes em 15/2/2013, 08:42

Você tentou também com CHAR(1)?
'1' = SIM
'0' = NÃO

??

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
http://portal.programacaobrasil.com

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por EdinaldoRocha em 15/2/2013, 16:27

Boa tarde Marcos.

Preferi usar char(3) "SIM","NÃO" e manipular atraves de uma combo para fazer um visual melhor no form sem ter que ficar programando conversão.

Obrigado.

EdinaldoRocha
Participa Pouco
Participa Pouco


Voltar ao Topo Ir em baixo

Resolvido Re: Problema de Campo Bit no CursorAdapter

Mensagem por Nelson Arcas em 18/2/2013, 11:00

Olá Edinaldo,
Verifiquei que voce achou uma solução, eu consegui fazendo de uma outra forma que achei mais pratica, todos os meus campos BIT transformei para numeric(1,0) e consegui utilizar sem problemas dentro do VFP
avatar
Nelson Arcas
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum