Clique abaixo para nos ajudar
Login

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
26 usuários online :: 1 usuário cadastrado, Nenhum Invisível e 25 Visitantes :: 2 Motores de busca

memarques

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
Últimos assuntos
» Ajuda a direcionar
Hoje à(s) 01:17 por miiiih

» Alterar uma palavra num arquivo de texto
5/12/2016, 12:02 por Teseu

» Buscar endereço por CEP
3/12/2016, 19:59 por pedrossian

» USAR WEBSERVICE NO VFP9
2/12/2016, 09:50 por AJC

» BANIMENTO DE USUARIO
17/11/2016, 08:31 por FAF

» Impressora Ticket
15/11/2016, 09:20 por clima238

» Gráfico
9/11/2016, 10:43 por hidroluz

» TRANSPOR TABELA
9/11/2016, 10:34 por hidroluz

» MUDANÇA DO .DBF PARA POTSGREE
9/11/2016, 09:12 por AJC

» Website com videoaulas sobre linguagens de programação
8/11/2016, 09:56 por JLDR

» Parceria para desenvolvimento de template em Wordpress
7/11/2016, 19:15 por mindix

» Data fica invertida na planilha que é gerada via programa.
27/10/2016, 11:00 por Linghston

» Maximizar report direto do menu
21/10/2016, 20:48 por Rosangela Pires

» Fechar form com tempo
21/10/2016, 10:15 por Rosangela Pires

» URGENTE: Ajuda com impressora ELGIN-L42
14/10/2016, 09:53 por megasoft

» Opções para gerar NF-e
10/10/2016, 09:07 por mavsinfo

» Google Maps
8/10/2016, 15:08 por Rosangela Pires

» Mysql
5/10/2016, 11:22 por Marcos Guedes

» Acessando Banco em MYSQL de um projeto WORDPRESS
3/10/2016, 10:58 por Marcos Guedes

» OPTION SELECT MOSTRAR CAMPOS QUASE PRONTO
26/9/2016, 21:09 por BobKuspe

Alterar uma palavra num arquivo de texto

5/12/2016, 12:02 por Teseu

Olá prezados colegas de programação!

Este é eu primeiro post no fórum e gostaria de poder …

Comentários: 0

Buscar endereço por CEP

3/12/2016, 19:59 por pedrossian

Caros amigos, meu código para buscar endereço pelo CEP não funciona mais.
Alguém pode me …

Comentários: 0

USAR WEBSERVICE NO VFP9

2/12/2016, 09:50 por AJC

Pessoal, preciso de um material ou livro que me traga instruções como
usar a consumação de …

Comentários: 0

BANIMENTO DE USUARIO

13/11/2016, 16:21 por FAF

A usuária ROSANGELA PIRES ao tentar acessar o Forum obtem sempre a mensagem de BANIMENTO.
A mesma …

Comentários: 3

Impressora Ticket

15/11/2016, 09:20 por clima238

Bom dia,
Por favor alguém me explique porque o código abaixo imprime no ecrã em vez do printer: …

Comentários: 0

Estatísticas
Temos 6963 usuários registrados
O último usuário registrado atende pelo nome de miiiih

Os nossos membros postaram um total de 17119 mensagens em 2577 assuntos

Grafico

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Grafico

Mensagem por mauro victoria em 6/2/2013, 18:21

Estou usando uma programa para geração de graficos e esta apresentando um erro que não consigo solucionar.
Podem ajudar-me.
Obrigado.
Link do programa
[Você precisa estar registrado e conectado para ver este link.]

erro esta na aba grafico - atualiza

* Cria string para leitura do msgraph.chart
Select Tabela
Afields(A_CAMPOS)
m.vlc_GData = ""
Scan
For x = 1 To Fcount()
m.vlc_chr = iif(x < Fcount(),Chr(9),Chr(13))
m.vlc_GData = m.vlc_GData + &A_CAMPOS[x,1] + m.vlc_chr
Endfor
Endscan
Go Top


* Cria cursor e adiciona o objeto.
Create Cursor Grafico ( MsGraphObj G )
Append Blank
APPENd General MsGraphObj Class "Msgraph.Chart" Data m.vlc_GData

*******************************************

O erro e o seguinte.
Ole erro code 0x800401f3:cadeia de caracteres de classe inválida.

Solucionando este erro acredito que esta rotina ajudara a muitos.

Até mais
.

mauro victoria
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por alceu11 em 6/2/2013, 19:16

Nao entendi ,,,,,,,,
testei aki o form grafico ke vc passou nao deu erro, algum........
Sera em kal dos graficos esta dando erro.?
[Você precisa estar registrado e conectado para ver esta imagem.]



image do grafico

[Você precisa estar registrado e conectado para ver esta imagem.]

alceu11
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por mauro victoria em 7/2/2013, 08:45

Bom dia Alceu agradeço pelo retorno, porem na minha maquina esta faltando alguma dll, já desinstalei o fox 8 e tornei a instalar porem o erro persiste.
Caso tenha alguma sugestão estou no aguardo dede já agradeço.

mauro victoria
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por alceu11 em 7/2/2013, 09:10

Eu estou executando o form no VFP9.
Acho que é a versao do vfp..
Teste de novo e nao deu erro

[Você precisa estar registrado e conectado para ver esta imagem.]

link da imagem



[Você precisa estar registrado e conectado para ver esta imagem.]

[Você precisa estar registrado e conectado para ver esta imagem.]

alceu11
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por Julio em 7/2/2013, 09:36

Utilizo o VFP 9 tb; testei aqui com varias combinações montagem grafico e não apresentou erro.


Julio
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por mauro victoria em 7/2/2013, 09:38

Aqui na empresa não tem vfp 9 da onde eu posso baixar?
Para testa esta rotina.
Obrigado.

mauro victoria
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por alceu11 em 7/2/2013, 10:22

Google
digite 4shared
No 4shared pesquise vfp9.rar
na 2 pagina da pesquisa.



alceu11
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por Julio em 7/2/2013, 10:47

Mauro

voce ja visitou este link?

clique aqui para visitar link

Julio
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por mauro victoria em 7/2/2013, 12:28

Instalei na minha maquina o vfp 9 e o erro persiste.
será Ole erro code 0x800401f3:cadeia de caracteres de classe inválida.
que esse erro em algum lugar defino tamanho tela ou memoria, porque
aqui numa maquina funciona e em outras 3 não , na minha e win 7 64 as outras sao xp

mauro victoria
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por alceu11 em 7/2/2013, 12:43

Funcionou em kal maquina,? com qual versao vfp?

SE FOR
window7 64 bits, 7,
copie as dll do vfp para pasta
\windows\SysWOW64, para aplicacao rodar.

alceu11
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por Julio em 7/2/2013, 13:32

Pessoal

Aqui tamem testei em uma maquina com Win 7 64 bits
Tive em uma aplicação que utilizava um oleboundcontrol, e nao funcionava em certas maquinas.
Resolvi o problema atualizando o pacote office.
Em uma maquina que nao funcionava resolvi instalando a ocx "MSCAL.OCX", que foi do office2003.

Fazendo uma pesquisa no google alguns erros de mesmo codigo foram resolvidos instalando "Microsoft OLE DB Provider for Visual FoxPro"

Aqui vai as ocx caso queira tentar.
Download aqui

Texto encontrado em [Você precisa estar registrado e conectado para ver este link.]
Cadeia de caracteres de classe inválida (0x800401f3)

ProgID ou CLSID especificado não foi registrado como um objeto OLE em uma instância do SQL Server. Servidores de automação OLE personalizados devem ser registrados antes de serem instanciados usando sp_OACreate. Isso pode ser feito com o utilitário Regsvr32.exe para servidores em processo (.dll) ou a opção de linha de comando /REGSERVER para servidores locais (.exe).

Julio
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por mauro victoria em 8/2/2013, 07:00

Bom dia pessoal, o gráfico só não funcionou na minha maquina porem em outras maquinas executou normalmente, alguma coisa esta interferindo e apresentando este erro vou da como resolvido a minha solicitação.

Obrigado e até mais

mauro victoria
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por alceu11 em 8/2/2013, 07:22

Eu acho que vc deveria dizer como resolveu , o erro, na maquina ke tem o windows xp, e as outras 2.

Mas eu descobri apos a dika do Julio. Instalei a OCX, que foi passada.

A partir do momento ke instalei o Office, com word e excel, no windows Xp pc_virtual,
o Grafico comecou a aparecer.
E acredito que as outras maquinas seja ausencia, do Pacote Office.


Agora nos outros Sistemas Operacionais, ke vc tem ai,
Vc tera ke nos dizer como o grafico, comecou a rodar.
vc instalaou algum OCX.? QUAL ?

Olha o trabalho que tivemos para te ajudar, nao digo somente eu , O Julio, busco alternativas muito boas. para voce.

Ficamos no aguardo. ja que vc nao mostra suas alternativas.

alceu11
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por Marcos Guedes em 8/2/2013, 08:39

Mauro, você não está utilizando algum componente GDI de terceiros?
Qual a diferença entre as máquinas onde rodam e onde não rodam corretamente?

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
[Você precisa estar registrado e conectado para ver este link.]

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por Julio em 13/2/2013, 15:56

Tambem gostaria de saber como resolveu!

Julio
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por mauro victoria em 14/2/2013, 10:28

Bom dia,

Sobre componente de GDI, não faço idéia do que seja, pois a diferença aqui é que na máquina com Windows XP (funciona o gráfico) e já na minha máquina que é windows 7, 64 Bites (não)...Já tentei instalar o OCX, mswinsck. ocx e nada.

Teria alguma outra maneira para que essa ferramente funcione em minha máquina?

Irei testar hoje na máquina do cliente e verificar se irá rodar e darei retorno.

mauro victoria
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por Julio em 18/2/2013, 09:09

Testei aqui na minha maquina com win 7 e em casa tb com win 7 o form que vc enviou, e funciona.
Pode dizer que isso nao tem nada a ver, tinha um cliente que reclamava de tudo e os outros nao e aqui tb funcionava tudo certo, na epoca com muita luta consegui formatar e reinstalar o windows na maquina do cliente o problema parou, era local.
O duro é convencer o pessoal disto que as vezes a windows esta com problema.
ALgumas DLL´s corrompidas com mal funcionamento, varias quedas de energia, isso ao meu ver vai causando dano, mas cada um pensa de uma forma.

Ja tentou reparar ou reinstalar o seu windows 7?

Julio
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por mauro victoria em 18/2/2013, 10:06

Bom dia Julio, no cliente e nas outras maquinas aqui do escritório funciona
porem, na minha em especifico não funciona. Estava tentando descobrir o porque, caso haja necessidade de instalar numa outra maquina de algum cliente que tb venha apresentar esse mesmo problema e eu ja tenha solução.
Quanta a reparar o windows 7 vou entrar em contato com o técnico para fazer este procedimento.

Obrigado e dou retorno.

mauro victoria
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Resolvido Re: Grafico

Mensagem por Conteúdo patrocinado Hoje à(s) 15:17


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum