Clique abaixo para nos ajudar
Conectar-se

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
22 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 22 Visitantes :: 2 Motores de busca

Nenhum

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
TRY BEGIN E FLOCK()

17/4/2017, 10:32 por AJC

Pessoal estou tendo alguns problemas de gravação em rede, estou usando
try begin, mas vi algo na …

Comentários: 0

Exportar Dados Campo Memo Tabela DBF

10/4/2017, 10:28 por fcampos

Olá bom dia.

Estou tentando exportar os dados de algumas tabelas em formato dbf pelo foxpro.
O …

Comentários: 2

Função EVL()

8/4/2017, 12:18 por Clebervfp

Bom dia a todos.
Vim compartilhar de uma Função do próprio VFP que me benefício muito.
Função …

Comentários: 0

COMO BLOQUEAR REGISTRO OU TABELA NO VISUAL FOXPRO PARA GRAVAÇÃO EM REDE

3/4/2017, 10:29 por AJC

Pessoal estou tendo um problema que acontece sempre busco na minha tabela de clientes o ultimo …

Comentários: 2

Controlar Scanner Twain

31/3/2017, 17:31 por Kleber R Bento

Estou usando o EZTW32.DLL para criar uma ferramenta que escaneia e gera PDF. Porém com esses …

Comentários: 0

Estatísticas
Temos 7063 usuários registrados
O último usuário registrado atende pelo nome de Bravera

Os nossos membros postaram um total de 47 mensagens em 24 assuntos

Problema com Webbrowser

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Em curso Problema com Webbrowser

Mensagem por BobKuspe em 22/2/2012, 18:31

Olá amigos,

Eu estou usando o WebBrowser do Rick Strahl modificado, mas a essência da navegação continua a mesma. O programa funciona muito bem, contudo, quando abro determinadas páginas, como cnn e outras que possuem muitos links, na barra de navegação ou address bar, em vez de aparecer a página que abri, fica aparecendo sucessivamente outros links, especialmente links relacionados a anúncios, facebooks, etc. Já procurei em diversos forums em inglês, modifiquei vários programas, mas de nada adianta. O que eu quero é que a url da address bar ou barra de navegação mantenha-se a mesma do site que abri até o momento em que decida navegar para outra página ou link.

Por favor, alguém pdoeria dar-me uma idéia ou um pedaço de código para aluminar o meu túnel?

Atenciosamente

Bob confused

BobKuspe
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Problema com Webbrowser

Mensagem por alceu11 em 23/2/2012, 07:26

Vc teria ke postar o teu Form , Para que possa fazer testes..

Aki no forum tem exemplo, ke esta neste video youtube. nao tive problemas, !!

[Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]
avatar
alceu11
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Em curso Re: Problema com Webbrowser

Mensagem por BobKuspe em 28/2/2012, 08:02

O meu Web browser abre toda e qualquer página. O problema é com "determinadas" páginas da Internet, como dos jornais elmundo dot es, elpais dot com, cnn dot com onde ele coloca no address bar, não apenas o link que abristes, muitos dos links existentes nestas páginas, especialmente os "ads". Ele não muda o conteúdo do "browser", mas sim, o conteúdo da barra de endereços.

Eis as partes principais de meu código:

FORM1.NAVIGATE

Código:
LPARAMETERS lcUrl
 
IF EMPTY(lcUrl)
  lcUrl = TRIM(THISFORM.txtUrl.DisplayValue)
ENDIF

*** Don't navigate
IF lcUrl = THISFORM.cCurrentUrl
  RETURN
ENDIF

IF !EMPTY(lcUrl)
  THISFORM.oBrowser.Navigate(lcUrl,0,NuLL,NULL,NULL)
ELSE
  THISFORM.oBrowser.GoHome()
ENDIF 

IF EMPTY(lcUrl)
  thisform.cCurrentUrl = "asasdasd"
ELSE
  THISFORM.cCurrentUrl = lcUrl
ENDIF

THISFORM.Resize()


oBROWSER.BEFORENAVIGATE2

Código:
LPARAMETERS pdisp, url, flags, targetframename, postdata, headers, cancel

lcURl = TRIM(url)
ACTIVATE SCREEN
CLEAR
? "Url: " + lcUrl


#IF .F.
*** Browser Cop Sample
IF ATC("west-wind.com",url) =  0 AND ATC("about:blank") = 0
  MESSAGEBOX("Busted! Stay on the West Wind Site buddy!",64,"Fox Browser")
  CANCEL = .T.
  RETURN
ENDIF 
#ENDIF
[code]

oBROSER.NAVIGATECOMPLETE2


[code]
*** ActiveX Control Event ***
LPARAMETERS pdisp, url
LOCAL x

ACTIVATE SCREEN
? "Navigated to Url: " + Url

IF EMPTY(Url)
RETURN
ENDIF

*** See if the item is already in the list
lcUrl = LOWER(Url)
FOR x = 1 TO thisform.txtUrl.ListCount
IF lcUrl == LOWER(TRIM(thisform.txtUrl.ListItem[x]))
THISFORM.txtUrl.RemoveListItem(x)
THISFORM.txtUrl.AddItem(Url,1)
THISFORm.txtUrl.Value = 1
RETURN
ENDIF
ENDFOR

thisform.txtUrl.AddItem(Url,1)
THISFORM.txtUrl.Value = Url

IF thisform.txtUrl.ListCount > 25
thisform.txtUrl.RemoveItem(26)
ENDIF

THISFORm.txtUrl.Value = 1[/code]

Por favor, preciso URGENTE resolver este problema. procurem testar o browser que vocês usam naqueles sites que possuem muitos "ads".

Abraço e obrigado pela atenção

BobKuspe
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Problema com Webbrowser

Mensagem por alceu11 em 28/2/2012, 08:22

Nao e tao urgente assim"""!!!"""
No dia 23 posta a resposta so agora 28/2, vc respondeu ke isto?

Cade o Teu Link do arquivo com o teu Form webbrowse, para testa-lo ondi esta ????

Olha com o exemplo ke tem no forum abro qualquer pagina sem travar...!!!
Se vc nao procuro o exemplo para baixar va na secao videos, e procure abrindo Ie no vfp
[Você precisa estar registrado e conectado para ver este link.]
Click no 4 botao na barra "Exemplo 3" ,,,,,,,,abir aki "cnn", nao tive problemas..

So ke sem o teu exemplo para testa-lo, como saberemos, ?

mas se vc ker codigo facil
aki vai um
*****
DECLARE INTEGER SetForegroundWindow IN user32.dll INTEGER
oIE = CREATEOBJECT("internetexplorer.application")
oIE.navigate("http://www.google.com/search?q="+"erro script IE"+"")
oIE.Visible = .T.
=SetForegroundWindow(oIE.HWND)
*****************
avatar
alceu11
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Em curso Re: Problema com Webbrowser

Mensagem por BobKuspe em 28/2/2012, 19:24

Amigo Alceu,

naquele momento estava com urgência do código, ainda preciso muito dele, mas há outras coisas que exigem muito mais de mim. A menos que alguém queira pagar meu cartão de crédito. Precisar do código eu preciso.

Acho que esqueci de dizer que havia feito o download de seu programa, conforme instruções suas. Não tinha aberto, contudo, este EXEMPLO número 3. O programa pede uma tabela "mitabla.dbf" que não consta no pacote.

Tudo bem, mesmo sem esta "tabela" foi possível abrir o executável "proj179" e abri o exemplo3. UAU! Eele mostra uma série de links, mas por fim permanece a url original.

Valeu, cara. Muitíssimo obrigado. Devo esta a você.

BobKuspe
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Problema com Webbrowser

Mensagem por BobKuspe em 28/2/2012, 19:43

Alceu,
Segue em anexo o "zip" do form de meu webbrowser que NÂO FUNCIONA CORRETAMENTE

Abraço e obrigado

BobKuspe
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Problema com Webbrowser

Mensagem por alceu11 em 28/2/2012, 23:27

Aki vai a tabela
CLOSE DATABASES
create table mitabla ( provincias c(15), nombre c(10), Favori c(120), usero c(30), data d(08))
index on provincias tag mitabla

objetivo era gravar as paginas proibidas ke usuarios entravam
e um deles perdeu o Cargo.
avatar
alceu11
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Em curso Re: Problema com Webbrowser

Mensagem por BobKuspe em 29/2/2012, 21:07

Valeu, Alceu, Muito obrigado. Very Happy

BobKuspe
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum