Clique abaixo para nos ajudar
Login

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
16 usuários online :: 1 usuário cadastrado, Nenhum Invisível e 15 Visitantes :: 2 Motores de busca

azengaroth

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
Últimos assuntos
» URGENTE - Instalação do aplicativo
Hoje à(s) 08:51 por Douglas Pascini

» Conexão Sql Server
Ontem à(s) 12:18 por Douglas Pascini

» como fazer essa imagem clicavel
22/1/2017, 13:56 por flavio dos reis

» USAR REPORT FORM
20/1/2017, 15:00 por ImRicoh

» Impressora Ticket
20/1/2017, 08:25 por ImRicoh

» Visite meu canal no Youtube
20/1/2017, 00:45 por ImRicoh

» Protocolo de comunicação porta serial
19/1/2017, 16:48 por rodiney

» Bloquear edição do ListBox
17/1/2017, 23:38 por Dipaula

» Ajuda em Script VBS
16/1/2017, 11:22 por carlosdantasf

» automação do mozilla e chrome
15/1/2017, 12:16 por Handerson Mildroz

» Aplicação Android algoritmos de aprendizagem pseudocódigo
4/1/2017, 01:09 por diegoveloper

» COMO ESTÃO DESENVOLVENDO EM WEB?
3/1/2017, 10:21 por felipe.palucoski

»  Um For não enxerga outro no DataGrid! (VIsual Basic)
2/1/2017, 12:44 por Ana Waldila

» C# criar checkBox Transparente
28/12/2016, 12:26 por flavio dos reis

» Menu lateral exemplo em VFP
28/12/2016, 11:55 por mxavier

» dll pertocheck
23/12/2016, 13:47 por FERNANDOMATRELLA

» Rota de um arquivo
23/12/2016, 09:01 por Julio

» BANIMENTO DE USUARIO
22/12/2016, 12:48 por Marcos Guedes

» USAR WEBSERVICE NO VFP9
20/12/2016, 18:33 por FAF

» CALCULO
19/12/2016, 18:48 por David Valerio

URGENTE - Instalação do aplicativo

24/1/2017, 08:51 por Douglas Pascini

Bom dia. Estou com um problema, ao fazer a instalação (colocar os arquivo) do aplicativo na …

Comentários: 0

Conexão Sql Server

23/1/2017, 12:18 por Douglas Pascini

Estou mudando meu servidor, para uma máquina remota. Até ai perfeito, o problema acontece que …

Comentários: 0

USAR REPORT FORM

30/12/2016, 09:06 por AJC

Pessoal bom dia,
Estou com um grande problema, já pesquisei muita coisa sobre report form, mas o …

Comentários: 3

Impressora Ticket

15/11/2016, 09:20 por clima238

Bom dia,
Por favor alguém me explique porque o código abaixo imprime no ecrã em vez do printer: …

Comentários: 2

Visite meu canal no Youtube

20/1/2017, 00:45 por ImRicoh

VFP Unlimited


Comentários: 0

Estatísticas
Temos 6993 usuários registrados
O último usuário registrado atende pelo nome de azengaroth

Os nossos membros postaram um total de 12 mensagens em 6 assuntos

Quando envio arquivo para mysql nao esta gravando

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Quando envio arquivo para mysql nao esta gravando

Mensagem por mauro victoria em 9/11/2010, 23:56

Enviando arquivo porem nao esta gravando.

Código:
myconnect = SQLSTRINGCONNECT(lcstringconn)
      IF myconnect > 0

         = sqlsetprop(myconnect, 'Transactions', 2) && Transações manuais

         m.comando = ""
         m.comando = "" + m.comando + [insert into boletim (matricula,NOME,turma,registro,nivel,nnivel,codprof,nomprof,codprof1,nomprof1,codprof2,]
         m.comando = "" + m.comando + [nomprof2,codprof3,nomprof3,codprof4,nomprof4,codcoord1,nomcoord1,codcoord2,nomcoord2,codcoord3,nomcoord3,codcoord4,]
         m.comando = "" + m.comando + [nomcoord4,modboletim,obs1,obs2,obs3,obs4,nota1_1,nota1_2,nota1_3,nota1_4,nota1_5,nota1_6,nota1_7,nota1_8,nota1_9,]
         m.comando = "" + m.comando + [nota1_10,nota1_11,nota2_1,nota2_2,nota2_3,nota2_4,nota2_5,nota2_6,nota2_7,nota2_8,nota2_9,nota2_10,nota2_11,]
         m.comando = "" + m.comando + [nota3_1,nota3_2,nota3_3,nota3_4,nota3_5,nota3_6,nota3_7,nota3_8,nota3_9,nota3_10,nota4_1,nota4_2,nota4_3,nota4_4,]
         m.comando = "" + m.comando + [nota4_5,nota4_6,nota4_7,nota4_8,nota4_9,nota4_10,nota5_1,nota5_2,nota5_3,nota5_4,nota6_1,nota6_2,nota6_3,]
         m.comando = "" + m.comando + [nota6_4,nbimestre,impresso1,impresso2,impresso3,impresso4,web1,web2,web3,web4,ok1,ok2,ok3,ok4 ) VALUES ]
         m.comando = "" + m.comando + [(?vmatricula,?vnome,?vturma,?vregistro,?vnivel,?vnnivel,?vcodprof,?vnomprof,?vcodprof1,?vnomprof1,?vcodprof2,]
         m.comando = "" + m.comando + [?vnomprof2,?vcodprof3,?vnomprof3,?vcodprof4,?vnomprof4,?vcodcoord1,?vnomcoord1,?vcodcoord2,?vnomcoord2,?vcodcoord3,?vnomcoord3,]
         m.comando = "" + m.comando + [?vcodcoord4,?vnomcoord4,?vmodboletim,?vobs1,?vobs2,?vobs3,?vobs4,?vnota1_1,?vnota1_2,?vnota1_3,?vnota1_4,?vnota1_5,]
         m.comando = "" + m.comando + [?vnota1_6,?vnota1_7,?vnota1_8,?vnota1_9,?vnota1_10,?vnota1_11,?vnota2_1,?vnota2_2,?vnota2_3,?vnota2_4,?vnota2_5,]
         m.comando = "" + m.comando + [?vnota2_6,?vnota2_7,?vnota2_8,?vnota2_9,?vnota2_10,?vnota2_11,?vnota3_1,?vnota3_2,?vnota3_3,?vnota3_4,?vnota3_5,]
         m.comando = "" + m.comando + [?vnota3_6,?vnota3_7,?vnota3_8,?vnota3_9,?vnota3_10,?vnota4_1,?vnota4_2,?vnota4_3,?vnota4_4,?vnota4_5,?vnota4_6,]
         m.comando = "" + m.comando + [?vnota4_7,?vnota4_8,?vnota4_9,?vnota4_10,?vnota5_1,?vnota5_2,?vnota5_3,?vnota5_4,?vnota6_1,?vnota6_2,?vnota6_3,]
         m.comando = "" + m.comando + [?vnota6_4,?vnbimestre,?vimpresso1,?vimpresso2,?vimpresso3,?vimpresso4,?vweb1,?vweb2,?vweb3,?vweb4,?vok1,?vok2,?vok3,]
         m.comando = "" + m.comando + [?vok4 )]

         sqlexec(myconnect , m.comando)
         = SQLCOMMIT(myconnect)

         sqldisconnect(myconnect)

porem com menos campos grava
exemplo:

      myconnect = SQLSTRINGCONNECT(lcstringconn)
      IF myconnect > 0

         = sqlsetprop(myconnect, 'Transactions', 2) && Transações manuais

         sqlexec(myconnect , [insert into boletim (matricula, nome, nota1_1,nota2_1 ) values (?vmatricula,?vnome,?vnota1_1,?vnota2_1)])
         = SQLCOMMIT(myconnect )

         sqldisconnect(myconnect)
      ELSE
         =AERROR(laerror)
         MESSAGEBOX("NAO FOI POSSIVEL CONECTAR-SE AO DB"+CHR(13)+;
         "LINHA"+laerror[2])
         EXIT
      ENDIF


mauro victoria
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Resolvido Re: Quando envio arquivo para mysql nao esta gravando

Mensagem por mauro victoria em 10/11/2010, 07:45

Achei o erro:
1) não estava na rotina, ela esta correta.
2) havia 2 campos que estavam fora da posição

mauro victoria
Participa Bastante
Participa Bastante


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum